Arrow Arrow - 3 months ago 5x
HTML Question

Yet Another "Why isn't my Favicon showing?"


I have just tried "Pinning" my site to the Taskbar again (after removing it) but when I clicked and held down the mouse button on the 16x16px icon inside the address bar (see pic below), you can see my favicon being dragged around with the mouse - so internet explorer has found and got the icon - it's just not displaying it in all the right places! Also updated code below:
enter image description here

As the title suggests, I can't get my favicon to display; in any version of any browser. There is 1 exception, though - which isn't good enough:

IE 9 and IE 10 -
enter image description here

As you can probably see in the screenshot above, the only time I get to see my favicon is after I've added it to my Favorites folder and opened the Favorites Bar. The favicon does not display in the Tab (next to the page title), it does not display in the Taskbar area, and it does not display up the top-left of the browser window if I have "Pinned" my site to the Taskbar.

In every other browser, it simply does not display at all.

I have tried every possible "solution" that I could find online.

Here's the code I have:

<link rel="icon" type="image/x-icon" href=""><!-- Major Browsers -->
<!--[if IE]><link rel="shortcut icon" href=""/><![endif]--><!-- Internet Explorer-->

I have also tried all common sizes for the favicon;
- and I've even tried saving all sizes within the same

I have tried deleting the cache file for

Nothing has worked. The exact same code has previously worked on other sites that I've made. I don't get it. What gives?


I've edited this answer, leaving only solution to problem presented in question.

Use: <link rel="shortcut icon" href="{ICONURL}"/>

Instead of: <link rel="icon" href="{ICONURL}"/>