Faber Faber - 2 months ago 51
Node.js Question

Meteor - rxjs@5.0.0-beta.11 or rxjs@5.0.0-beta.6 UNMET DEPENDENCY

i have this problem with meteor project with angular2, if i install ( with meteor npm install ) the package rxjs5.0.0-beta.11 the nam says:

@angular/router@3.0.0-alpha.8 requires a peer of rxjs@5.0.0-beta.6 but none was installed.


If i install the package rxjs@5.0.0-beta.6 the nam says :
"

npm WARN @angular/core@2.0.0-rc.6 requires a peer of rxjs@5.0.0-beta.11 but none was installed.
npm WARN angular2-google-maps@0.14.0 requires a peer of rxjs@5.0.0-beta.11 but none was installed.


"

Typical answer of the problem "dog chasing its tail", if i install the beta.11 it's required beta.6 and if i install beta.6 the requirements it's beta.11
This is my package.json

{
"name": "angular2-meteor-base",
"private": true,
"scripts": {
"start": "meteor run",
"test": "meteor test --driver-package practicalmeteor:mocha",
"test:ci": "meteor test --once --driver-package dispatch:mocha-phantomjs"
},
"devDependencies": {
"chai": "3.5.0",
"chai-spies": "0.7.1"
},
"dependencies": {
"@angular/common": "2.0.0-rc.6",
"@angular/compiler": "2.0.0-rc.6",
"@angular/core": "2.0.0-rc.6",
"@angular/forms": "0.2.0",
"@angular/platform-browser": "2.0.0-rc.6",
"@angular/platform-browser-dynamic": "2.0.0-rc.6",
"@angular/router": "3.0.0-alpha.8",
"angular2-google-maps": "^0.14.0",
"angular2-meteor": "0.6.2",
"angular2-meteor-accounts-ui": "^0.6.1",
"angular2-meteor-auto-bootstrap": "0.6.0",
"angular2-meteor-polyfills": "0.1.1",
"angular2-meteor-tests-polyfills": "0.0.2",
"es6-shim": "0.35.1",
"meteor-node-stubs": "0.2.3",
"ng2-pagination": "^0.3.5",
"reflect-metadata": "0.1.3",
"rxjs": "5.0.0-beta.6",
"zone.js": "0.6.12"
}
}

Answer

Update these 3 in your package.json

"@angular/router": "3.0.0-rc.2",
"rxjs": "5.0.0-beta.11",
"zone.js": "^0.6.17"

You can refer latest package.json here

See if this helps.

Comments