thepule thepule - 3 months ago 8
R Question

geom_lollipop (package Ggalt) not working

I am following the tutorial on how to use

geom_lollipop
, from the package
ggalt
at the following link.

The code I am trying to run is the following:

df <- read.csv(text="category,pct
Other,0.09
South Asian/South Asian Americans,0.12
Interngenerational/Generational,0.21
S Asian/Asian Americans,0.25
Muslim Observance,0.29
Africa/Pan Africa/African Americans,0.34
Gender Equity,0.34
Disability Advocacy,0.49
European/European Americans,0.52
Veteran,0.54
Pacific Islander/Pacific Islander Americans,0.59
Non-Traditional Students,0.61
Religious Equity,0.64
Caribbean/Caribbean Americans,0.67
Latino/Latina,0.69
Middle Eastern Heritages and Traditions,0.73
Trans-racial Adoptee/Parent,0.76
LBGTQ/Ally,0.79
Mixed Race,0.80
Jewish Heritage/Observance,0.85
International Students,0.87", stringsAsFactors=FALSE, sep=",", header=TRUE)


library(ggplot2)
library(scales)
library(ggalt)


gg <- ggplot(df, aes(y=reorder(category, pct), x=pct))
gg <- gg + geom_lollipop(point.colour="steelblue", point.size=3, horizontal=TRUE)
gg <- gg + scale_x_continuous(expand=c(0,0), labels=percent,
breaks=seq(0, 1, by=0.2), limits=c(0, 1))
gg <- gg + labs(x=NULL, y=NULL,
title="SUNY Cortland Multicultural Alumni survey results")
gg <- gg + theme_minimal(base_family="Arial Narrow")
gg <- gg + theme(panel.grid.major.y=element_blank())
gg <- gg + theme(panel.grid.minor=element_blank())
gg <- gg + theme(axis.line.y=element_line(color="#2b2b2b", size=0.15))
gg <- gg + theme(axis.text.y=element_text(margin=margin(r=-5, l=0)))
gg <- gg + theme(plot.margin=unit(rep(30, 4), "pt"))
gg <- gg + theme(plot.title=element_text(face="bold"))
gg


Instead of creating a lollipop plot, my output is the following:
lollipop

It appears that
geom_lollipop
is not working. Also when I try to digit geom_lollipop, Rstudio does not seem to find it among the available functions.

I thought it was a problem of package version, but I have updated R and reinstalled all the packages above. Following the versions of R and libraries in use:

> packageVersion("ggalt")
[1] ‘0.1.1’
> packageVersion("ggplot2")
[1] ‘2.1.0’
> packageVersion("scales")
[1] ‘0.4.0’
> R.version
_
platform x86_64-apple-darwin13.4.0
arch x86_64
os darwin13.4.0
system x86_64, darwin13.4.0
status
major 3
minor 3.1
year 2016
month 06
day 21
svn rev 70800
language R
version.string R version 3.3.1 (2016-06-21)
nickname Bug in Your Hair


Any idea why this is not working?

Answer

(updated from comment)

Works for me with ggalt_0.3.0.9000 scales_0.4.0 ggplot2_2.1.0.

Maybe you need the Github/devel version? Try restarting session/unloading ggalt, then

devtools::install_github("hrbrmstr/ggalt")

and reload the package.

Comments