Atilla Csaholczi Atilla Csaholczi - 1 month ago 14
C++ Question

Visual Studio 2015 Missing Universal templates

I've been having this problem for about a month, and I am completely stuck.

Under the "New Project" window I don't see the windows 10 universal templates, but have the sdk and tools installed.

All pictures are in this folder on dropbox.

New Project Window: Capture.png (on dropbox)

What I tried:


  • .net 3.5 enable/disable under "programs and features"/"Turn Windows features on or off"

  • full uninstall/reinstall with VisualStudioUninstaller

  • full uninstall/reinstall with Revo Uninstaller

  • iso intaller

  • running "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE>devenv /installvstemplates" command with admin privileges

  • repairing with original installer

  • modifying with original installer



The strange thing is that in the installer (when modifying) the Universal Windows App Development checkbox is checked. (Capture1.png ... Capture5.png)

I have, however, found out that the folders at "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\ProjectTemplates\VC\Windows Root\Windows UAP\1033" is completely empty... Isn't that supposed to be the template folder for the projects? (Capture6.png)

I would be grateful if you could give me some advice fixing this issue.

Answer

Okay, so for anyone having this problem:

Check if the "Windows Installer" service is running under Task Manager/Services.

If not right click and select Start service.

After that run the installer for Visual Studio and select repair.

After the repairing finishes, (reboot if you want, it wasn't required for me) all the templates are installed.

(And yes, if you still have this problem, write to microsoft, they are helpful in these kinds of questions)

Comments