lopes710 lopes710 - 3 months ago 36
iOS Question

Tealium framework "dyld: Library not loaded:" error using cocoapods

I have installed a pod in podfile:
pod 'TealiumIOS', '~> 5.0'

But an error occurs in runtime.

"dyld: Library not loaded: @rpath/TealiumIOS.framework/TealiumIOS
Referenced from: ...
Reason: image not found"

I can't find the solution in any other stackoverflow posts. I'm running XCode 7.3 and I tried simulator and a real device. Pods version 1.0.1. The crash persists.

Thank you.

Answer

I had a similar problem, so probably my solution is going to be useful for you as well.

Looks to be that Tealium pod was created just as a framework option and you are using cocoapods with the static library option. Basically you have to add the use_frameworks! option in the podfile.

platform :ios, 8.1
use_frameworks!

target :YourTarget
    pod 'TealiumIOS'
end

Enjoy :)

Comments