Adrian Soleil Adrian Soleil - 1 year ago 457
jQuery Question

Meteor-Bootstrap jQuery wrong version

I do have the following message in the console:

Uncaught Error: Bootstrap's JavaScript requires at least jQuery v1.9.1 but less than v3.0.0

In .meteor > version file it says it's

  • I did tried to meteor remove and the install again both jquery and boostrap separately.

  • Also tried to manualy change current version in .meteor version file to 1.9.1 first in terminal it says:
    jquery upgraded from 1.9.1 to 1.11.9

    But after server restart the current version is back to 1.11.9

What can be done to retrieve the favor of the javascript gods?

Answer Source

This may happen when you have other npm packages with jQuery dependency defined as >= 1.9.1

In that case, if no other package defines a more strict version, npm will automatically take the most recent version that complies with this dependency specification, i.e. jQuery 3+ in that case.

If you are in that situation, a simple workaround is to add a more strict version specification in your package.json file, e.g. "jquery": ">=1.9.1 <3.0.0"

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download