Julia Julia - 20 days ago 7
Linux Question

Installing PyQt (for pyuic4) after sip install goes OK: error: PyQt-x11-gpl-4.11 install

After installing

sip
, I keep getting this lovely error message when trying to install
PyQt-x11-gpl-4.11
.

mycommandline$ python configure-ng.py --verbose

Querying qmake about your Qt installation...

Determining the details of your Qt installation...

/usr/bin/qmake -o qtdetail.mk qtdetail.pro

make -f qtdetail.mk

g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. -o qtdetail.o qtdetail.cpp
g++ -m64 -Wl,-O1 -o qtdetail qtdetail.o -L/usr/lib/x86_64-linux-gnu -lQtCore -lpthread

Error: Failed to determine the detail of your Qt installation.


I can't really figure out what it means. Is it a dependency issue?

Answer

Assuming you're using ubuntu, there's no need to compile from source just to get pyuic4. If you install the correct official packages, everything should be included.

Just install either this:

  • Python 2: python-qt4 and pyqt4-dev-tools

Or this:

  • Python 3: python3-pyqt4 and pyqt4-dev-tools
Comments