Mateusz Kubuszok Mateusz Kubuszok - 11 days ago 4x
Linux Question

Cannot install roxygen2 on Debian Jessie

When I try to install

I get:

> sudo Rscript -e 'install.packages("roxygen2", repos="")'
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'text/plain' length 106197 bytes (103 Kb)
opened URL
downloaded 103 Kb

* installing *source* package ‘roxygen2’ ...
** package ‘roxygen2’ successfully unpacked and MD5 sums checked
** libs
g++ -I/usr/share/R/include -DNDEBUG -I"/usr/lib/R/site-library/Rcpp/include" -fpic -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g -c RcppExports.cpp -o RcppExports.o
g++ -I/usr/share/R/include -DNDEBUG -I"/usr/lib/R/site-library/Rcpp/include" -fpic -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g -c isComplete.cpp -o isComplete.o
g++ -I/usr/share/R/include -DNDEBUG -I"/usr/lib/R/site-library/Rcpp/include" -fpic -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g -c leadingSpaces.cpp -o leadingSpaces.o
g++ -I/usr/share/R/include -DNDEBUG -I"/usr/lib/R/site-library/Rcpp/include" -fpic -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g -c parser2.cpp -o parser2.o
parser2.cpp: In function ‘Rcpp::CharacterVector find_includes(std::string)’:
parser2.cpp:165:35: error: too many arguments to function ‘void Rcpp::stop(const string&)’
stop("Failed to open %s", path);
In file included from /usr/lib/R/site-library/Rcpp/include/RcppCommon.h:131:0,
from /usr/lib/R/site-library/Rcpp/include/Rcpp.h:27,
from parser2.cpp:1:
/usr/lib/R/site-library/Rcpp/include/Rcpp/exceptions.h:195:17: note: declared here
inline void stop(const std::string& message) {
/usr/lib/R/etc/Makeconf:137: recipe for target 'parser2.o' failed
make: *** [parser2.o] Error 1
ERROR: compilation failed for package ‘roxygen2’
* removing ‘/usr/local/lib/R/site-library/roxygen2’

The downloaded source packages are in
Warning message:
In install.packages("roxygen2", repos = "") :
installation of package ‘roxygen2’ had non-zero exit status

I tried several different repos, but result is always the same. Is it a problem with version that got published in repos? What else could I try?


Hadley noticed this problem with other packages and stated on a Github thread that the solution is to use the dev verstion of Rcpp, i.e.


So, upgrade Rcpp then fully shutdown all RStudio and R processes, then restart and reinstall roxygen2.