Johshi Johshi - 2 months ago 9
Android Question

Latest version of gradle can't be found

The latest version of Gradle is 2.14.1, right? Therefore, I have this:

gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip


gradle.build

buildscript {
repositories {
mavenCentral()
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:2.14.1'
}
}


But Android studio says it can't find it.

Answer

The version of the Android Gradle Build tool is completely independent of Gradle.

For example, yes, current recommended Gradle is 2.14.1 or higher, but the latest stable Android Gradle Build tool is 2.2.0

classpath 'com.android.tools.build:gradle:2.2.0'