Learner Learner - 4 months ago 44
Linux Question

How to install libc.so.6(GLIBC_2.14)(64bit) on sles11

I cant figure out how do I resolve this issues,
When I'm trying to install

rsyslog-module-gtls
on my suse linux 11 ,It says

warning: rsyslog-module-gtls-7.2.5-2.2.1.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 3dbdc284
error: Failed dependencies:
libc.so.6(GLIBC_2.14)(64bit) is needed by rsyslog-module-gtls-7.2.5-2.2.1.x86_64
libgnutls.so.28()(64bit) is needed by rsyslog-module-gtls-7.2.5-2.2.1.x86_64
libgnutls.so.28(GNUTLS_1_4)(64bit) is needed by rsyslog-module-gtls-7.2.5-2.2.1.x86_64
rsyslog = 7.2.5 is needed by rsyslog-module-gtls-7.2.5-2.2.1.x86_64


And after that if I do
rpm -i glibc-64bit-2.17-4.4.1.ppc.rpm


I'm getting conflict errors:

warning: glibc-64bit-2.17-4.4.1.ppc.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 3dbdc284
package glibc-64bit-2.17-4.4.1.ppc is intended for a ppc architecture
file /lib64/libBrokenLocale.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libSegFault.so from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libanl.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libc.so.6 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libcidn.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libcrypt.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libdl.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libm.so.6 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnsl.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_compat.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_dns.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_files.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_hesiod.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_nis.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libnss_nisplus.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libpthread.so.0 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libresolv.so.2 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/librt.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libthread_db-1.0.so from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64
file /lib64/libutil.so.1 from install of glibc-64bit-2.17-4.4.1.ppc conflicts with file from package glibc-2.11.3-17.95.2.x86_64


Any help will be highly appreciated.Thank you

Answer

you have the wrong rpm; it says clearly:

package glibc-64bit-2.17-4.4.1.ppc is intended for a ppc architecture

try looking for one on http://rpm.pbone.net/index.php3; I found a candidate here:

ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home%3A/bmwiedemann%3A/branches%3A/Base%3A/System/openSUSE_Factory/

there you need to choose your architecture. Check your architecture using the command

uname -m
Comments