Omer Janjua Omer Janjua - 4 months ago 6
iOS Question

iOS 8.1 Push Notification No Sound

The device is running on iOS 8.1

I'm using xCode 6.1 to compile the app.

This is the code to register for push

if ([[[UIDevice currentDevice] systemVersion] floatValue] >= 8.0)
[application registerUserNotificationSettings:[UIUserNotificationSettings settingsForTypes:(UIUserNotificationTypeSound | UIUserNotificationTypeAlert | UIUserNotificationTypeBadge) categories:nil]];
[application registerForRemoteNotifications];
[application registerForRemoteNotificationTypes: (UIUserNotificationTypeBadge | UIUserNotificationTypeSound | UIUserNotificationTypeAlert)];

It works fine as the app registers with the server.

The PEM files are also done correctly as I can send a push to my device using sandbox APN.

When I print my JSON payload from
I get this:

aps = {
alert = "Test Push Message";

The issue is when I receive my push (even when the device is set to loud) it doesn't play no sound.

From my knowledge if you don't specify a sound in the JSON payload it should play the default OS sound.

In my App notification settings on the phone the sound is enabled by default because when I register I specify

Anyone else come across this issue?


According to Apple's documentation you need to specify default if you want to the default push notification to be played:

The name of a sound file in the app bundle. The sound in this file is played as an alert. If the sound file doesn’t exist or default is specified as the value, the default alert sound is played. The audio must be in one of the audio data formats that are compatible with system sounds; see Preparing Custom Alert Sounds for details.

The final JSON output:

    "aps" :     {
        "alert" : "Test Push Message",
        "sound" : "default"