Grant Grant - 3 months ago 23
Java Question

Hibernate 4.1.9 : Which jar files do I need?

I started to learn Hibernate framework from "Hibernate 3.2 in Simple Steps" book, but I downloaded latest version of Hibernate which is 4.1.9. According to the book there are many essential jars we need to add to the class path like


  • Anttr-2.7.6.jar

  • asm.jar

  • asm-attrs.jar

  • cglib-2.1.3.jar

  • commons-collections-2.1.1.jar

  • commons-logging-1.0.4.jar

  • .
    .
    . etc.



But I can't find all those required jars in new version. So what can I do without going for an old version ?? Do I just only need to add jars in required folder,,, can any one please tell me what jars I should need to add class path (4.1.9 version).
This question may be silly but I'm a beginner and I'm stuck here. Please help me.
Thank you!

Answer
antlr-2.7.7.jar
commons-collections-3.2.1.jar
dom4j-1.6.1.jar
javassist-3.12.1.GA.jar
hibernate-core-4.0.1.Final.jar
hibernate-commons-annotations-4.0.1.Final.jar
hibernate-jpa-2.0-api-1.0.1.Final.jar
jboss-logging-3.1.0.CR2.jar
jboss-transaction-api_1.1_spec-1.0.0.Final.jar

The zip file which you download will have a required folder inside lib.It will be having all the necessary jars.

Comments