user1898014 user1898014 - 2 months ago 10x
Android Question

Resolved: ERROR: "._android-support-v4.jar" in project FacebookSDK

Help needed!!!! Stuck for 2 weeks on this and help needed.

I've recently imported the facebook sdk for android and its projects into my workspace. It shows up errors and the problems:

Archive for required library: '/home/Documents/facebook-android-sdk-3.0.2.b/facebook/libs/._android-support-v4.jar' in project 'FacebookSDK' cannot be read or is not a valid ZIP file

And the samples get errors along the line of:

The container 'Android Dependencies' references non existing library '/home/Documents/facebook-android-sdk-3.0.2.b/facebook/bin/facebooksdk.jar'

The things I have done following the other discussions without any success are

cleaned project

set the Facebook SDK as library

looked at the build path section and added external jar consisting of facebook/libs

imported fb sdk like 20 times and into different folders.

made sure my java compiler was 1.6

HELP would be very greatly appreciated!!!!


Take the lastest version of android-support-v4.jar (in your sdk environement : sdk/extras/android/support/v4/android-support-v4.jar) and replace in your project and library project do not create conflict.