GetGalax GetGalax - 2 months ago 58
PHP Question

Warning: mCrypt extension needs to be loaded for OpenCart to work

I'm trying to install OpenCart but get the following warning:
"Warning: mCrypt extension needs to be loaded for OpenCart to work!"

Since I'm a noob on this, could someone point me in the right direction on how to solve this? Google don't really help me out here :(

Thanks!

Answer Source

So you said you have FTP access and you can edit php.ini.

If the server has mcrypt installed but not enabled then if you add:

extension=mcrypt.so

then save php.ini and upload, this should work. Note that some servers don't load user's php.ini, instead they are looking for a .user.ini file in root folder.

I would suggest you, if my above answer doesn't help you to contact your hosting provider.