SFun28 SFun28 - 2 months ago 24
R Question

Trouble installing RJSONIO library

I'm having some trouble installing RJSONIO. install.packages tells me that the package is not available for my version of R. I can manually download the binary and install, but then I can't use the library because it is "not installed for 'arch=x64'"

workarounds?

> install.packages('RJSONIO')
Installing package(s) into ‘C:/R/site-library’
(as ‘lib’ is unspecified)
Warning in install.packages :
package ‘RJSONIO’ is not available (for R version 2.13.0)
>
> install.packages( "C:\\downloads\\RJSONIO_0.7-2.zip" , repos = NULL )
Installing package(s) into ‘c:/R/site-library’
(as ‘lib’ is unspecified)
package 'RJSONIO' successfully unpacked and MD5 sums checked
>
> library(RJSONIO)
Error: package 'RJSONIO' is not installed for 'arch=x64'

Answer

Try building it from source if you have the appropriate tools installed.

from http://www.omegahat.org:

install.packages("RJSONIO", repos = "http://www.omegahat.org/R", type = "source")