Mertcan Mertcan - 1 month ago 26
Java Question

mvn cannot clean deploy (failure)

I'm having problem while deploying and here is the error message I get:

[INFO] --- maven-deploy-plugin:2.7:deploy (default-deploy) @ core ---
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3.296 s
[INFO] Finished at: 2014-11-26T17:05:00+02:00
[INFO] Final Memory: 13M/244M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:
deploy (default-deploy) on project core: Deployment failed: repository element w
as not specified in the POM inside distributionManagement element or in -DaltDep
loymentRepository=id::layout::url parameter -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1]

I checked some resources on internet and none of them worked for my case. I think it's related to my pom.xml. Here is the related parts of pom.xml:


<name>Spring Framework Maven Release Repository</name>

So what do you think the problem might be ?
Thanks in advance.


You should include the repository where you want to deploy in the distribution management section of the pom.xml.


<project xmlns=""   xmlns:xsi=""   xsi:schemaLocation="
      <name>Corporate Repository</name>