Theo Theo - 5 months ago 14
Android Question

Android - PLUGIN IS TOO OLD,PLEASE UPDATE TO A MORE RECENT VERSION OR SET ANDROID_DAILY_OVERRIDE

I have just updated my android studio. The current version is Android Studio 2.0 Preview 6. However I am getting the message described in the title of this post.
I tried to play with the gradle version inside the dependecies of the gradle file,but nothing happens. Here is my file.

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
repositories {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:2.0.0-alpha6'

// NOTE: Do not place your application dependencies here; they belong
// in the individual module build.gradle files
}
}

allprojects {
repositories {
jcenter()
}
}

task clean(type: Delete) {
delete rootProject.buildDir
}


Is there any specific value of gradle that I should put,in order to fix the problem? Some people fixed it by using the version of gradle:1.5.0.

Thanks

Answer

Here is the full answer from my comments.

You need to use the same version of gradle for all submodules of your project. You can see a list of submodules by choosing "Android" presentation in you Project View and expand "Gradle Scripts" section. You will see all build.gradles that are included into your project.

Comments