ExecAssa ExecAssa - 16 days ago 5
Apache Configuration Question

HTTP/2.0 with WampServer 3.0.6 doesn't work

I wanna try the new version of http protocol ( http2 ) and specially the server_push function on the last version of WampServer ( 3.0.6, with 2.4.23 Apache version and OpenSSL/1.0.2h ).

I have activated the http2_module ( ssl module is activated by default ) and configured it to give priority at http2 in TLS and clearText connections.

httpd.conf file :

<IfModule http2_module>
LogLevel http2:info
Protocols h2 h2c http/1.1
</IfModule>


And restart services.

But when I launch the localhost page, a basic PHP script page or phpinfo, the protocol version used by Apache is always HTTP/1.1

I use browsers like Chrome ( version 54.0.2840.99 m ) or Firefox ( version 50.0 ).

If you have ideas to resolve the problem?

Answer

No browser supports HTTP/2 without HTTPS (h2c) so you must use TLS for HTTP/2. https://http2.github.io/faq/#does-http2-require-encryption

Additionally HTTP/2 requires strong encryption so as well as TLS you need to ensure you are not using these ciphers: https://http2.github.io/http2-spec/#BadCipherSuites