ihue ihue - 1 month ago 21
PHP Question

The localhost page isn’t working on Laravel 4

I've not been working on Laravel 4 environment for about 2 years now. Now, I'm trying to help a friend out, and make some modification to the site. While trying to get the site up and running, I faced some errors.




Here is what I've did


  • clone the project from repository

  • composer update

  • chmod -R 777
    to public/ and vendor/ and bootstrap/

  • Now, my file permission look like this



-rw-r--r-- 1 bheng staff 252 Oct 26 19:05 test.php
-rwxr-xr-x 1 bheng staff 519 Oct 26 19:05 server.php
-rwxr-xr-x 1 bheng staff 1913 Oct 26 19:05 readme.md
drwxrwxrwx 17 bheng staff 578 Oct 26 19:05 public
-rwxr-xr-x 1 bheng staff 566 Oct 26 19:05 phpunit.xml
-rwxr-xr-x 1 bheng staff 2062 Oct 26 19:05 error_log
-rwxr-xr-x 1 bheng staff 1027 Oct 26 19:05 composer.json
drwxrwxrwx 5 bheng staff 170 Oct 26 19:05 bootstrap
-rwxr-xr-x 1 bheng staff 2451 Oct 26 19:05 artisan
-rw-r--r-- 1 bheng staff 1507527 Oct 26 19:05 app.zip
drwxr-xr-x 15 bheng staff 510 Oct 26 19:05 app
-rwxr-xr-x 1 bheng staff 26287 Oct 26 19:05 README
-rwxr-xr-x 1 bheng staff 145 Oct 26 19:05 CONTRIBUTING.md
-rw-r--r--@ 1 bheng staff 0 Oct 26 19:12 Icon?
-rw-r--r-- 1 root staff 105493 Oct 26 19:20 composer.lock
drwxr-xr-x 28 bheng staff 952 Oct 26 19:48 vendor



  • I am using MAMP in my Mac OS.

  • I've tried look into my app.php

  • I have set the correct URL as
    'url' => 'http://localhost:8888',

  • Now when I go to the site I kept getting




The localhost page isn’t working


enter image description here




Update

I've tried rename my
index.php
to
index_.php


and add this content to my
index.php


<?php
phpinfo();
?>


Now, I got my php.ini page to load.

enter image description here




How do I take it from here ?

How would one go about and debug this ?




I'm opening to any suggestions at this moment.

Any hints / suggestions / helps on this be will be much appreciated !

Answer

You should also apply correct write permissions to the /app/storage folder. This will show you where you have the error.

Comments