pableiros pableiros - 4 months ago 92
iOS Question

How to install a specific version of cocoapods repo

This is my

Podfile
:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'RMQClient', '~> 0.8'


When I try to install the repo from cocoapods with
pod install
, it installs me a new version from
pod 'RMQClient'
(the 0.9 for example).

In another
xcode project
with the same
Podfile
, I made a
pod update
and the cocoapods it update the pod repo:


Installing RMQClient 0.9.0 (was 0.8)


How can I prevent the
cocoapods
update the pod repos when I do a update?
How can I force to install the version I set in the
Podfile
?

Answer

Your error is in ~>

Try

pod 'RMQClient', '0.8'

Update:

Check repo tags.

A correct repo tags should be like:

enter image description here

And i can see that the RMQClient have:

enter image description here

Take in considerention the v character. I'm not sure, but it could be the inconvenient