Catalin Catalin - 4 days ago 4x
Ruby Question

What's the easiest way to edit a dependency in a gem stored on GitHub

I'm trying to install a

from GitHub, but in the gemspec a dependency version makes installing the gem impossible. All I need is to edit that version.

What's the easiest way of doing this so I can make the gem usable in my app ?


You can fork it, modify the gemspec by changing the version of dependency and after that to install this gem in your app by defining

gem 'your_gem', :git => 'git://