Praveen Pandey Praveen Pandey - 5 months ago 19
Android Question

Could not find com.google.gradle:osdetector-gradle-plugin:1.2.1

I have been following documentation at the location - https://github.com/grpc/grpc-java/blob/master/SECURITY.md
Error:Could not find com.google.gradle:osdetector-gradle-plugin:1.2.1.
I have searched through net , I am not able to find any solution .
Thanks .

Answer

99% probability is that the version number 1.2.1 does not exist.

The documentation referenced in your question specifies 1.4.0 everywhere.

Change the version to 1.4.0 and it should resolve if the version number is the problem.

compile 'com.google.gradle:osdetector-gradle-plugin:1.4.0'
Comments