humazed humazed - 2 months ago 125
Android Question

Using version 1.0.0-alpha7 of the constraint library, which is obsolete

I'm start using android studio 2.2 and try to play with ConstraintLayout but when I let android studio add it automatically it shows me that error

Using version 1.0.0-alpha7 of the constraint library, which is obsolete


when I try to upgrade it using quick fix I get that error

Error:Could not find com.android.support.constraint:constraint-layout:1.0.0-alpha8.


I think this is a bug in android studio, what should I do to fix it.

my current solution is to suppress the error.

Answer

You need to install ConstraintLayout for Android inside Support Repository package on SDK Tools category of SDK Manager.