Taco Taco - 1 month ago 19x
Swift Question

Realm support for Swift 3.0

I was wondering whether it is already possible to use Realm with the beta of Swift 3.0.

Although I see a RealmSwift-swift3.0 directory in in the Realm repo, I do not succeed to use it correctly. How should I install it from source?


You can use Realm with Swift 3.0, but take into account that the current version is still absolutely experimental.

You can clone the master branch of the realm-cocoa repo from GitHub.

Or you can use Carthage:

github "realm/realm-cocoa.git" "master"

Or if you prefer CocoaPods:

pod 'RealmSwift', :git => 'https://github.com/realm/realm-cocoa.git', :branch => 'master'

If you use Carthage, remember that you must add Realm and RealmSwift frameworks manually (ignore the IBAnimatable framework):

Project configuration image

In fact, I have one of my projects with Xcode 8, Swift 3 and Realm, and it works perfectly :)