iDev iDev - 9 days ago 5
iOS Question

Watch kit CFBundleVersion

Planning for watch kit integration

error: The value of CFBundleVersion in your WatchKit app's Info.plist (1) does not match the value in your companion app's Info.plist (2.0). These values are required to match.

Struck with above error.

- changed the deployment targets of both notification & watchkit app. But build failed

Thanks.

Answer

You need to make sure that the CFBundleVersion in the Info.plist of your WatchKit App is identical to the CFBundleVersion in your parent app’s Info.plist.