arcee123 arcee123 - 3 months ago 72
Node.js Question

why rxjs keeps not being the right version?

I'm trying to install a node/angular2 solution on cloud9. Here is my package.json

{
"name": "example",
"version": "0.0.0",
"private": true,
"scripts": {
"start": "node ./bin/www",
"postinstall": "typings install",
"typings": "typings",
"vendor": "gulp vendor",
"gulp": "gulp clean && gulp",
"build:production": "gulp clean && gulp build && node systemjs.builder.js"
},
"dependencies": {
"@angular/common": "2.0.0-rc.5",
"@angular/compiler": "2.0.0-rc.5",
"@angular/core": "2.0.0-rc.5",
"@angular/forms": "0.3.0",
"@angular/http": "2.0.0-rc.5",
"@angular/platform-browser": "2.0.0-rc.5",
"@angular/platform-browser-dynamic": "2.0.0-rc.5",
"@angular/router": "3.0.0-rc.1",
"@angular/upgrade": "2.0.0-rc.5",
"body-parser": "~1.15.2",
"cookie-parser": "~1.4.3",
"core-js": "^2.4.1",
"debug": "~2.2.0",
"express": "~4.14.0",
"hbs": "~3.1.0",
"mongoose": "^4.5.8",
"mongoose-unique-validator": "^1.0.2",
"morgan": "~1.6.1",
"reflect-metadata": "^0.1.3",
"rxjs": "5.0.0-beta.11",
"serve-favicon": "~2.3.0",
"systemjs": "0.19.36",
"zone.js": "^0.6.12"
},
"devDependencies": {
"del": "^2.2.1",
"gulp": "^3.9.0",
"gulp-sourcemaps": "^1.6.0",
"gulp-typescript": "^2.10.0",
"systemjs-builder": "^0.15.26",
"typings": "^1.3.2"
}
}


In spite of how this is written, I keep getting this error during
npm install
:

npm WARN @angular/http@2.0.0-rc.5 requires a peer of rxjs@5.0.0-beta.6 but none was installed.
npm WARN @angular/router@3.0.0-rc.1 requires a peer of rxjs@5.0.0-beta.6 but none was installed.
npm WARN @angular/core@2.0.0-rc.5 requires a peer of rxjs@5.0.0-beta.6 but none was installed.


when I try to run the solution I keep getting this error:

UNMET PEER DEPENDENCY rxjs@5.0.0-beta.11


I tried changing the package.json to beta.6, and it still fails.

does anyone have any wisdom on this?
Thanks.

Answer
  1. Update package.json to use "rxjs": "5.0.0-beta.6",
  2. Delete node_modules directory in project folder.
  3. Run npm install

That should fix it. I use your package.json with rxjs 5 beta6, the installation was successful without any issue.

Comments