Gladwin Gladwin - 25 days ago 10
Android Question

Affdex Gradle Failed to resolve

I’m not able to add dependency. It keeps throwing me the error, Failed to resolve com.affectiva.android:affdexsdk:3.2 . I’ve added maven repository but still it’s giving me error.

Project Gradle:

allprojects {
repositories {
jcenter()
maven { url "https://maven.google.com" }
maven { url "http://maven.affectiva.com" }
maven { url 'https://jitpack.io' }
}
}


App Gradle:

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:appcompat-v7:26.1.0'
compile 'com.android.support.constraint:constraint-layout:1.0.2'
compile 'com.affectiva.android:affdexsdk:3.2'
testCompile 'junit:junit:4.12'
}


I get this following error

Error:(28, 13) Failed to resolve: com.affectiva.android:affdexsdk:3.2

Answer Source

Your gradle setup should work however http://maven.affectiva.com/ reports a problem: "The specified bucket does not exist"

I would ask in the official community of Affectiva if there are any problems related to the repo.