Data Mechanics Data Mechanics - 10 days ago 6
Linux Question

PHP Xdebug Netbeans Breakpoints

After working fine, with no config changes for months xdebug/netbeans is now useless.
I can create breakpoints but whenever it has 'stepped in' to a further scope its impossible to step thru and simply jumps out of the inner scope to the caller.
There are no exceptions generated.

Using tail -f xdebug.log shows breakbpoints being correctly created / removed, Netbeans failed to remove from Ubuntu Software Centre, however I reinstalled over the top of existing. This does not seem clean as Netbeans remembered settings.

Latest steps:



Ran instructions at https://xdebug.org/wizard.php and rebooted webserver
Of note here it recommended install of xdebug-2.4.1 instead of previously 2.4.0 however this made no difference to current state of NetB / Xdebug combo. I checked php-fpm ini and this correct phpized version still ?

Ran uninstall.sh at /usr/local/netbeans8.*

Downloaded re-install at http://www.oracle.com/technetwork/articles/javase/jdk-netbeans-jsp-142931.html (I also need Java JDK so this is ideal)
Made it executable and ran installer (as sudo)

chmod +x jdk-8u101-nb-8_1-linux-x64.sh;
./jdk-8u101-nb-8_1-linux-x64.sh;


And nothing changes - this is very frustrating that software designers still cannot be a***d to create proper uninstallers. Still same settings prior to re-install.

Further



Closed NetBeans again

cdl /home


then check in each user dir

rm -r .netbeans
rm -r NetBeansProjects


There was also a directory called nbproject near the site root directory and in the sitefiles repo which is gitted - these was removed.

Update



Now set up the project including the crap Netbeans debug 'stop at first line' and allowing watches (whats the point of these defaults in a generally used framework norm such as laravel and what is debugging without being able to look at variable values).
Its now begun allowing stepping thru code but after closing debug session will now not allow access to run config. Had to close all projects and reopen.
This proves that its a Netbeans issue - WTF did it get so c**p.

Answer

Seems the problem went - maybe on IDE update ?