superRain superRain - 2 months ago 17
Swift Question

Update cocoapods to desired version

We use cocoapods IQKeyboardManagerSwift in our project but IQKeyboardManagerSwift has updated Swift 3.0 to version

4.0.6
. In the pod file, I wrote:

pod 'IQKeyboardManagerSwift' , '~> 4.0.5'


Then, after installation , I found that it is still version
4.0.6

Answer

The line below asks for version 4.0.5 or greater

'IQKeyboardManagerSwift', '~> 4.0.5'

and this line asks for version 4.0.5 exactly

'IQKeyboardManagerSwift', '4.0.5'
Comments