Jed Jed - 1 month ago 11
R Question

r-base-dev won't install due to dependencies

I'm new to stackoverflow, R and Ubuntu...here goes. I have a windows machine running a virtual Ubuntu machine with Oracle VM Virtual box. My Ubuntu is 32 bit and was installed as part of a Coursera course on data mining.

I am trying to get word2vec.c and word2phrase.c to compile and be used in R by using the system command. I've done a bunch of research and found that pthread.h is not supported on windows machines so I thought I would install R on the Ubuntu virtual machine to solve this problem. I have followed the instructions to install R on Ubuntu found here: http://sites.psu.edu/theubunturblog/installing-r-in-ubuntu/ When I install the base R package with

sudo apt-get install r-base
it works fine, but when I try to install the r-base-dev applications with
sudo apt-get install r-base-dev
I get the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
r-base-dev : Depends: build-essential but it is not going to be installed
Depends: cdbs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I have tried to install build-essential, but I get a warning/error message like this:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I go tried to install dpkg-dev, and it's dependencies until I reach a dead-end with this warning:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
dpkg-dev : Depends: libdpkg-perl (= 1.17.5ubuntu5) but 1.17.5ubuntu5.3 is to be installed
Recommends: build-essential but it is not going to be installed
Recommends: fakeroot but it is not going to be installed
Recommends: libalgorithm-merge-perl but it is not going to be installed


There appears to be circular logic here where it recommends build-essntial but I was trying to install libdpkg-perl so I could install build-essential...I must be missing something here Please help!

I've read enough to know that I need the R development kit to use install.packages in R, so if I can't resolve this issue, I won't be able to install or include any standard libraries in my R scripts.

Jed Jed
Answer

In the end the priblem was that the Ubuntu image I downloaded was corrupted. I re-downloaded it and the problem went away.