Sanjay Yaduvanshi Sanjay Yaduvanshi - 23 days ago 9
MySQL Question

Liferay 7 with MySQL Server 5.6 not starting

I’d just downloaded latest Liferay 7 Tomcat bundle


Extracted it and stared from liferay-ce-portal-7.0-ga3\tomcat-8.0.32\bin\startup.bat. Server started successfully and first screen opened on browser. Then I provided basic configurations and database (MySQL Server 5.6) details etc. and re-stared server as instructed. But now whenever I’m starting the server, throwing following exception and server is not starting. Can anyone help me to identify the issue please?

10:23:40,085 INFO [localhost-startStop-1][BaseDB:501] Database does not support case sensitive queries
You must first upgrade to Liferay Portal 7002
10:23:40,097 ERROR [localhost-startStop-1][MainServlet:237] java.lang.RuntimeException: You must first upgrade to Liferay Portal 7002
java.lang.RuntimeException: You must first upgrade to Liferay Portal 7002
at com.liferay.portal.servlet.MainServlet.processStartupEvents(
at com.liferay.portal.servlet.MainServlet.init(
at javax.servlet.GenericServlet.init(
at org.apache.catalina.core.StandardWrapper.initServlet(
at org.apache.catalina.core.StandardWrapper.loadServlet(
at org.apache.catalina.core.StandardWrapper.load(
at org.apache.catalina.core.StandardContext.loadOnStartup(
at org.apache.catalina.core.StandardContext.startInternal(
at org.apache.catalina.util.LifecycleBase.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployDescriptor(
at org.apache.catalina.startup.HostConfig$
at java.util.concurrent.Executors$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Stopping the server due to unexpected startup errors


You seem to have pointed Liferay to a database with existing data. In that case you'll have to run the upgrade routines before starting Liferay. This is a separate tool starting with version 7.0 - it used to be bundled within the server in prior versions. The documentation should contain all required information.

Answering your comment: The line

10:23:40,097 ERROR [localhost-startStop-1][MainServlet:237] java.lang.RuntimeException: 
You must first upgrade to Liferay Portal 7002

clearly indicates that Liferay found the tables and data structure from a previous version in the database that you're pointing to. Note that a file will also be picked up if it's in the current user's home directory - that might override the settings that you expect to set in the installation's private or

In addition, I do recommend to explicitly use a mysql-driver version matching your mysql-server version. Otherwise Liferay will download a driver from the maven repositories and it might not match 100%. I've seen problems arise from that.