johnsonjp34 johnsonjp34 - 6 months ago 55
iOS Question

Updating a CocoaPod

I'm using a GoogleMaps pod in my xcode workspace.

I followed https://developers.google.com/maps/documentation/ios-sdk/start#step_1_get_the_latest_version_of_xcode for setup about a year ago.

I've got a new computer and when I open my workspace project I get

Podfile.lock: No such file or directory
Manifest.lock: No such file or directory
"The sandbox is not in sync with the Podfile.lock. Run pod install or update your Cocoapods installation.


I updated my cocoapods installation.

I then ran pod update. And also pod install. In both cases I continue to get a message that says :

! The dependency 'GoogleMaps' is not used in any concrete target.


The podfile that I am using:

source 'https://github.com/CocoaPods/Specs.git'
pod 'GoogleMaps'


Finally I tried deleting the podfile and the Pods folder and ran pod install and I still get that error message. I've tried it with both a platform ios target of 8.1 and 9.0.

Answer

By reinstalling cocoapods on your system, I guess you downloaded a newer version of it, so the Podfile syntax changed a little bit, what you're missing is the target, you can read more about this here

So in your case it would be something like this:

source 'https://github.com/CocoaPods/Specs.git'

target 'App target'
pod 'GoogleMaps'

Just run pod install after that and that's all.

Comments