Kais Kais - 17 days ago 23
Android Question

npm WARN jest-react-native@17.0.0 requires a peer of whatwg-fetch@^1.0.0 but none was installed

When I try to run npm install in ReactNative project, I get this error.To solve this I try to install whatwg-fetch@^1.0.0 also but same error .

UNMET PEER DEPENDENCY whatwg-fetch@2.0.1

npm WARN jest-react-native@17.0.0 requires a peer of whatwg-fetch@^1.0.0 but none was installed.
npm ERR! code 1

Answer

you need to manually install missing peer dependencies
npm install whatwg-fetch@^1.0.0 --save

Comments