HungCLo HungCLo - 15 days ago 5
Swift Question

Can not compile when using the SwiftyJSON in iOS

I would like to add SwiftyJSON to my app.

I install it using the terminal and create a Podfile in the same folder.

I follow all the steps onSwiftyJSON on github. When I compile the xcode, it turns out the error:

enter image description here

It seems that I did not have a module called

SwiftyJSON.modulemap
.

What's wrong with that?

Answer

If you are working in swift 2.3 the pod is:

pod 'SwiftyJSON', '~> 2.4'

This is the pod that working properly.