eadjeikusi eadjeikusi - 1 month ago 19
Android Question

Error with minSdk version

I am trying to support Android 4.0 devices.

I keep getting following errors.

How do I fix them?


Error:Execution failed for task ':app:processReleaseManifest'.

Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version 16 declared in library
[com.github.mark-dlc:RadioPlayerService:88b5de0] C:\Users\Emmanuel\Documents\Android Development\xspace\3\app\
build\intermediates\exploded-aar\com.github.mark-dlc\RadioPlayerService\88b5de0\AndroidManifest.xml

Suggestion: use tools:overrideLibrary="co.mobiwise.library" to force usage

Answer

Your RadioPlayerService will not work in devices less than API 16

minSdkVersion cannot be smaller than version 16 declared in library com.github.mark-dlc:RadioPlayerService

Options:

  1. Find a new library
  2. Remove that library
  3. Follow the suggestion in the message "use tools:overrideLibrary="co.mobiwise.library" to force usage", and pray that it works (probably won't work, though)
Comments