Furqan Misarwala Furqan Misarwala - 23 days ago 13
MySQL Question

After installation, WAMP server is not starting in windows 10

Downloaded: http://www.wampserver.com/en/

WAMPSERVER 64 BITS (X64) 3.0.6


  • Wampserver 3.0.6 64 bit x64

  • Apache 2.4.23

  • PHP 5.6.25/7.0.10

  • MySQL 5.7.14

  • PhpMyAdmin 4.6.4

  • Adminer 4.2.5

  • PhpSysInfo 3.2.5



After installation, WAMP serveris not starting in windows 10.

Following is the error log:


State of services:

The service 'wampapache64' is NOT started
EXIT error code:1066
Help message for error code 1066 is:

The service has returned a service-specific error code.

The service 'wampmysqld64' is started

The service 'wampmariadb64' is started

The service 'dnscache' is started

WampServer (Apache, PHP and MySQL) will not function properly if any service

'wampapache64'

'wampmysqld64'

'wampmariadb64'

'dnscache'

is not started.


Yes MSVC installed :

enter image description here

Event log :


The Apache service named reported the following error:
AH00015: Unable to open logs .

The Apache service named reported the following error:
AH00451: no listening sockets available, shutting down .

The Apache service named reported the following error:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address 0.0.0.0:80 .

The Apache service named reported the following error:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address [::]:80 .

The wampapache64 service terminated with the following service-specific error:
Incorrect function.

Answer Source

Finally got a solution : https://stackoverflow.com/a/36034867/221919

I checked with command for the usage of port 80,

cmd

netstat -ao

Found culprit

enter image description here

After changing port from 80 to 8080 as

enter image description here

It works:

enter image description here