Android_Dev Android_Dev - 1 month ago 26
Android Question

Android Studio LLDB 2.2 update issue

Today I updated my android studio to version V-2.2.2. When I am trying to debug my android application with native code(app-native) I am always getting error message


C++ debugger package is missing or incompatible, do you want to fix it.


enter image description here

After updating to lldb 2.2 also I am getting same issue when I try to debug my native c++ code.

enter image description here

I am using gradle plug in 'com.android.tools.build:gradle-experimental:0.8.2' for building native ndk code. I have even updated ndk-bundle to latest version 13.0.3315539

Is anybody facing similar issue or able to resolve similar issue.

Thanks in advance.

Answer

I resolved issue by performing following steps

  1. Go to android-sdk folder on your file System, Locate folder lldb and delete folder lldb. (

For safety purpose you can keep backup or rename folder.

) 2. Now from android studio Tools->Android->SDK Manager->SDK Tools and update lldb option. Click on Apply. It will download LLDB 2.2 3. Now try to debug C++ code and debugging is working fine as expected.

Issue was arising due to some conflict between older downloaded version LLDB 2.1 and newer LLDB version 2.2