piotrek piotrek - 16 days ago 4
Java Question

Is there any spring support for kafka 0.8.2.2?

I'd like to use spring support to integrate with kafka. the server version is 0.8.2.2 but all the spring projects i could find uses newer kafka. even spring-kafka-1.0.0 uses kafka 0.9.0.1. and i read that kafka client's is not backward compatible. so the question is: is there any spring support for older kafka version or i have to get official kafka client and do it by myself?

Answer

Spring Cloud Stream 1.0.x versions supports kafka binder with kafka version 0.8.2.2. Spring Integration Kafka 1.3.x version also uses Kafka 0.8.2.2.