Deus Ralph Deus Ralph - 6 days ago 6
C++ Question

Unknown module QT: webkit

I am trying to make a simple webview in Qt 5.6

in my .pro file I have

QT += webkitwidgets


I have this Error:

:-1: error: Unknown module(s) in QT: webkitwidgets

Answer

Starting from Qt 5.6 Qt WebKit was removed:

https://wiki.qt.io/New_Features_in_Qt_5.6

With Qt 5.6 the following modules are no longer part of the release packages, but users can still build them from source: Qt WebKit

So if you still want to use WebKit you need 5.5 or earlier or you need to build your own version from sources.

Comments