Misha Moroshko Misha Moroshko - 4 months ago 5x
Ruby Question

How to install RedCloth on Windows?

When running

gem install RedCloth
(on Windows XP) I got:

Fetching: RedCloth-4.2.8.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
Successfully installed RedCloth-4.2.8
1 gem installed
Installing ri documentation for RedCloth-4.2.8...
Installing RDoc documentation for RedCloth-4.2.8...
ERROR: While generating documentation for RedCloth-4.2.8
... MESSAGE: error generating index.html: Error while evaluating D:/Programs/R
.rhtml: undefined method `[]' for nil:NilClass (RDoc::Error)
... RDOC args: --op D:/Programs/Ruby/lib/ruby/gems/1.9.1/doc/RedCloth-4.2.8/rdoc
--charset=UTF-8 --line-numbers --title RedCloth --main README.rdoc lib lib/case
_sensitive_require ext README.rdoc COPYING CHANGELOG --title RedCloth-4.2.8 Docu
mentation --quiet

Why do I get this error ?

Then I added
require 'RedCloth'
, and tried to run
rails s
, but unfortunately I got:

D:/Programs/Ruby/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/lib/redcloth.rb:12:in `
require': no such file to load -- 1.9/redcloth_scan (LoadError)
Couldn't load 1.9/redcloth_scan
The $LOAD_PATH was: ...

What am I doing wrong ?

I use Rails 3.0.1, Ruby 1.9.2.

bundle show RedCloth

=> D:/Programs/Ruby/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8


Here is my workaround to your second error, "Couldn't load 1.9/redcloth_scan", which looks like a bug of RedCloth on Windows. After gem install RedCloth --no-rdoc, I run

cd c:\Ruby192\lib\ruby\gems\1.9.1\gems\RedCloth-4.2.8\lib
mkdir 1.9
copy redcloth_scan.so 1.9

You should replace that directory with your path, "D:\Programs\Ruby\lib\ruby\gems\1.9.1\gems\RedCloth-4.2.8\lib", of course.