Meysam Meysam - 3 months ago 11
Node.js Question

Error while installing "materializecss" with npm

I'm trying to install

materialize-css
with
npm
:


npm install materialize-css --save-dev


But I get the following error:


2887 error node v4.2.4

2888 error npm v2.14.12

2889 error code EPEERINVALID

2890 error peerinvalid The package es6-shim@0.33.13 does not satisfy its siblings' peerDependencies requirements!

2890 error peerinvalid Peer angular2@2.0.0-beta.17 wants es6-shim@^0.35.0


What does this error mean and how can I fix it?

Answer

Try to delete the entire node_modules folder and re run npm install

Comments