Nisar Ahmad Nisar Ahmad - 3 years ago 388
Ruby Question

cocoapods permission issue in High Sierra?

I updated my macOS to High Sierra, Now installing dependencies through cocoapods in my iOS application. But I face the following error.

XXXXXXXXX:MyProject CompanyName$ pod update
-bash: /usr/local/bin/pod: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter: No such file or directory


Than i tried

Zubair-mac-mini:~ sdsol$ gem install cocoapods

ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.
Zubair-mac-mini:~ sdsol$


any help would be greatly appreciated.

Answer Source

Finally I found a solution after a lot of search.

1: Update your terminal to the latest version.

2: Download and Update RubyGems to the latest version from: https://rubygems.org/pages/download

3: Thin I update my pod file. through pod update.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download