gabriel gabriel - 22 days ago 10
Android Question

Crosswalk : build for android api 15

I need to target an android 4.0.4 device with crosswalk, on a ionic app.

In my config.xml, I have :

<preference name="android-minSdkVersion" value="15"/>


With
ionic run android
, crosswalk run into an error and ask me for a minimal android version of 16.

Is there a way to get it working with the android api 15 ?
Thanks

---EDIT
With
Ionic browser list
I have the following version of crosswalk avalaible.

Available - Crosswalk - ionic browser add crosswalk
Version 8.37.189.14 Published
Version 9.38.208.10 Published
Version 10.39.235.15 Published
Version 11.40.277.7 Published
Version 12.41.296.5 Published
(beta) Version 13.42.319.6 Published
(canary) Version 14.42.334.0 Published


I tried all versions, all of them get the same error.
I noticed that they all install this plugin
cordova-plugin-crosswalk-webview 2.1.0
, that might be a part of the problem ?

Answer

I finally found the solution here. 1/ add <preference name="xwalkVersion" value="17+" /> to config.xml 2/ follow the badboyunited solution : remove android platform, add crosswalk plugin via cordova, add android platform.