Jemru Jemru - 8 days ago 6
PHP Question

php_oci8.dll - Unable to load dynamic library

I have Windows 7 64bit, IIS 7, and installed PHP on IIS. I enabled php_oci8.dll for Oracle connection, but I'm getting the following error:

PHP Warning: PHP Startup: Unable to load dynamic library
'C:\Program Files (x86)\PHP\v5.5\ext\php_oci8.dll' -
The specified module could not be found.
in Unknown on line 0


I have checked that the php_oci8.dll exist in: 'C:\Program Files (x86)\PHP\v5.5\ext\php_oci8.dll'

My php.ini below:

extension_dir="C:\Program Files (x86)\PHP\v5.5\ext\"
[PHP_OCI8]
extension=php_oci8.dll


I downloaded Oracle Instant Client 32 bit at http://www.oracle.com/technetwork/topics/winsoft-085727.html. Then I extract the it and set the directory in Environment Variable "Path".

However I'm still getting the same error.

Answer

I have found the fix, I should install instantclient-basic-nt-11.2.0.3.0.zip 32bit. Earlier I installed the Oracle Client version 10. I tried to install the version 10 first because it worked when I install it in PHP 5.5/ IIS 8 / Windows 2012 Server. So it's weird why the IIS 8 in PHP 5.5 accepts Instant Client 10, while IIS 7 in PHP 5.5 doesn't accept Instant Client 10, but needs Oracle Instant Client 11. So the lesson is to try different Oracle Instant Client versions. Thanks.

Comments