tchakravarty tchakravarty - 2 months ago 18
Linux Question

CentOS 6.5 R Installation Dependencies

Update:



Please note that I did post a different flavor of this on the Unix & Linux SE, but received no helpful responses in the day before re-posting here. The information from that post that is relevant here is that I first added EPEL 7 to the list of repos using
rpm -Uvh
which is probably why the EL 7 version of R is being requested.

Anyway, as requested by user Sami Laine, here is the output from
cat /etc/yum.repos.d/epel.repo


[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1


And the output from
rpm -q epel-release
is
epel-release-6-8.noarch
.




I am trying to install R on a fresh CentOS 6.5 box, but am running into difficulties with dependencies. I added the EPEL 6 repo using
rpm
, and then ran a
yum install R
. It aborted with broken dependencies:

---> Package R-core.x86_64 0:3.1.1-3.el7 will be installed
--> Processing Dependency: libtiff.so.5(LIBTIFF_4.0)(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: liblzma.so.5(XZ_5.0)(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libquadmath.so.0()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: liblzma.so.5()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libicuuc.so.50()(64bit) for package: R-core-3.1.1-3.el7.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: R-core-3.1.1-3.el7.x86_64
---> Package R-java.x86_64 0:3.1.1-3.el7 will be installed
--> Processing Dependency: java-headless for package: R-java-3.1.1-3.el7.x86_64
---> Package texlive-texmf-errata-fonts.noarch 0:2007-7.1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: liblzma.so.5()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: liblzma.so.5(XZ_5.0)(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libtiff.so.5()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libpcre.so.1()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libpng15.so.15()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libicui18n.so.50()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libquadmath.so.0()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: R-java-3.1.1-3.el7.x86_64 (epel)
Requires: java-headless
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libicuuc.so.50()(64bit)
Error: Package: R-core-3.1.1-3.el7.x86_64 (epel)
Requires: libtiff.so.5(LIBTIFF_4.0)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Not sure why these dependencies are not getting resolved. Also any reason why el7 version is being installed when my CentOS is 6.5?

Answer

Since EPEL release 7 has been installed (and then removed), some of metadata used by dependency chain checking contains conflicting residue from that. Though you have installed EPEL release 6, the metadata is still left there to bother.

To clean metadata and generate it again, run:

yum clean all && yum makecache