Manu Antony Manu Antony - 1 month ago 17
Android Question

NativeScript installation Errors - npm fibers

Notes:

Node version 7.0.0
JavaJDK version 1.8.0.112
Android API 22 and studio installed:


I have been following the installation instructions on the native script website and am failing to get it to install at all.
I have setup all my environment variables correctly for JAVA_HOME and ANDROID_HOME
But whenever I try to install the nativescript cli i get errors like this:enter image description here

I tried looking up the internet for some solutions and found some initial clues on trying to edit the fibers module source code as given here :
I have tried building the fibers module by force

npm build -f


in the npm fibers directory. Since the nativescript installation fails I also cant run the tns doctor for any log trace:
enter image description here
I would greatly appreciate any suggestions to help me fix this. Do let me know if you need any more information. Apologies if my english isn't great as it is not my first language .

Answer

You are using Node version which is not supported yet, bellow is list of possible version as stated at http://docs.nativescript.org/start/ns-setup-win or other two version for Linux/Mac. Downgrade to 6.x version or you can use nvm, manager which can be used with several Node versions at same PC

The latest Node.js 0.10.x, 0.12.x, 4.x, 5.x, or 6.x stable official release