servatj servatj - 3 months ago 17
Ruby Question

Can't install ruby 2,3 with rbenv (Ubuntu server 16)

Hi all i've tried to install ruby with rbenv..

rbenv install 2.3.0


The shell get stuck in this line

Installing ruby-2.3.1...


After 10 min i cancel the process and get this log ..

linking transcoder gb18030.so
compiling ./enc/trans/gbk.c
linking transcoder gbk.so
compiling ./enc/trans/iso2022.c
make[1]: *** wait: No child processes. Stop.
make[1]: *** Waiting for unfinished jobs....
make[1]: *** wait: No child processes. Stop.


Any idea of what it's happening ? How can i clean all the process to restart the install?

Thanks in advance!

Answer

Once rbenv has determined which version of Ruby your application has specified, it passes the command along to the corresponding Ruby installation.

Each Ruby version is installed into its own directory under ~/.rbenv/versions. For example, you might have these versions installed:

~/.rbenv/versions/1.8.7-p371/
~/.rbenv/versions/1.9.3-p327/
~/.rbenv/versions/jruby-1.7.1/

Version names to rbenv are simply the names of the directories in ~/.rbenv/versions.

To remove old Ruby versions, simply rm -rf the directory of the version you want to remove. You can find the directory of a particular Ruby version with the rbenv prefix command, e.g. rbenv prefix 1.8.7-p357.

The ruby-build plugin provides an rbenv uninstall command to automate the removal process.

You may also want to update rbenv. If you've installed it manually then do

$ cd ~/.rbenv
$ git pull

You should also be able to update ruby-build by

$ cd ~/.rbenv/plugins/ruby-build
$ git pull

Sources

Comments