anoop4real anoop4real - 11 days ago 11
iOS Question

Mandatory App Transport Security January 2017 impact of existing apps

By Jan 2017 ATS is going to be mandatory, we are doing the required modification but not sure about bringing the App update by that time. Now the question is will the existing apps continue working? Will the apps out there stop working after Jan 2017 if we don't update the app?

Answer

Existing apps will continue to work as they do today. The new checks are only being done at the time of submitting the app to Apple for review.

Keep in mind that if there is a critical fix you need to put in on January 1st, 2017, you want to be in position to do so. Without the exceptions removed from your Info.plist, you may not be able to put in a quick fix.

Also, another clarification: Apple is allowing some exceptions to go through, but you would need to provide justification for why you still need the ATS exceptions (servers aren't under your control). But to have a blanket NSAllowsArbitraryLoads exception, we don't know what justification will be accepted by Apple.