prudhvi prudhvi - 17 days ago 4
Linux Question

Error while trying to mount S3 bucket into Ubuntu 14.04 EC2 instance

I have tried the following link to mount S3 bucket into EC2 :

https://forums.aws.amazon.com/message.jspa?messageID=313009


I started typing the following commands :

wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/s3fs/s3fs-1.74.tar.gz

tar zxf s3fs-1.74.tar.gz


The next command to type is this :

apt-get install build-essential libxml2-dev libfuse-dev libcurl4-openssl-dev


But, when I type this, I get the following response :

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
binutils cpp cpp-5 dpkg-dev fakeroot g++ g++-5 gcc gcc-5 icu-devtools libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libasan2 libatomic1
libc-dev-bin libc6-dev libcc1-0 libcilkrts5 libcurl3 libdpkg-perl libfakeroot libfile-fcntllock-perl libgcc-5-dev libgomp1 libicu-dev libisl15 libitm1 liblsan0
libmpc3 libmpx0 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libquadmath0 libselinux1-dev libsepol1-dev libstdc++-5-dev libtsan0 libubsan0 linux-libc-dev make
manpages-dev
Suggested packages:
binutils-doc cpp-doc gcc-5-locales debian-keyring g++-multilib g++-5-multilib gcc-5-doc libstdc++6-5-dbg gcc-multilib autoconf automake libtool flex bison gdb
gcc-doc gcc-5-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libmpx0-dbg
libquadmath0-dbg glibc-doc libcurl4-doc libcurl3-dbg libidn11-dev libkrb5-dev libldap2-dev librtmp-dev libssl-dev pkg-config zlib1g-dev icu-doc libstdc++-5-doc
make-doc
The following NEW packages will be installed:
binutils build-essential cpp cpp-5 dpkg-dev fakeroot g++ g++-5 gcc gcc-5 icu-devtools libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
libasan2 libatomic1 libc-dev-bin libc6-dev libcc1-0 libcilkrts5 libcurl3 libcurl4-openssl-dev libdpkg-perl libfakeroot libfile-fcntllock-perl libfuse-dev
libgcc-5-dev libgomp1 libicu-dev libisl15 libitm1 liblsan0 libmpc3 libmpx0 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libquadmath0 libselinux1-dev
libsepol1-dev libstdc++-5-dev libtsan0 libubsan0 libxml2-dev linux-libc-dev make manpages-dev
0 upgraded, 48 newly installed, 0 to remove and 0 not upgraded.
Need to get 49.5 MB of archives.
After this operation, 196 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libpcrecpp0v5 amd64 2:8.38-3.1 [15.2 kB]
Get:2 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libmpc3 amd64 1.0.3-1 [39.7 kB]
Get:3 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial-updates/main amd64 binutils amd64 2.26.1-1ubuntu1~16.04.3 [2,310 kB]
Get:4 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libc-dev-bin amd64 2.23-0ubuntu3 [68.7 kB]
Err:5 http://security.ubuntu.com/ubuntu xenial-security/main amd64 linux-libc-dev amd64 4.4.0-45.66
404 Not Found [IP: 54.87.136.115 80]
Get:6 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libc6-dev amd64 2.23-0ubuntu3 [2,084 kB]
Get:7 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libisl15 amd64 0.16.1-1 [524 kB]
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 cpp-5 amd64 5.4.0-6ubuntu1~16.04.2
Get:9 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 cpp amd64 4:5.3.1-1ubuntu1 [27.7 kB]
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcc1-0 amd64 5.4.0-6ubuntu1~16.04.2
Ign:11 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgomp1 amd64 5.4.0-6ubuntu1~16.04.2
Ign:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libitm1 amd64 5.4.0-6ubuntu1~16.04.2
Ign:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libatomic1 amd64 5.4.0-6ubuntu1~16.04.2
Ign:14 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libasan2 amd64 5.4.0-6ubuntu1~16.04.2
Err:5 http://security.ubuntu.com/ubuntu xenial-security/main amd64 linux-libc-dev amd64 4.4.0-45.66
404 Not Found [IP: 54.87.136.115 80]
Ign:15 http://security.ubuntu.com/ubuntu xenial-security/main amd64 liblsan0 amd64 5.4.0-6ubuntu1~16.04.2
Ign:16 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libtsan0 amd64 5.4.0-6ubuntu1~16.04.2
Ign:17 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libubsan0 amd64 5.4.0-6ubuntu1~16.04.2
Ign:18 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcilkrts5 amd64 5.4.0-6ubuntu1~16.04.2
Ign:19 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libmpx0 amd64 5.4.0-6ubuntu1~16.04.2
Err:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 cpp-5 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Ign:20 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libquadmath0 amd64 5.4.0-6ubuntu1~16.04.2
Ign:21 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgcc-5-dev amd64 5.4.0-6ubuntu1~16.04.2
Ign:22 http://security.ubuntu.com/ubuntu xenial-security/main amd64 gcc-5 amd64 5.4.0-6ubuntu1~16.04.2
Get:23 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 gcc amd64 4:5.3.1-1ubuntu1 [5,244 B]
Ign:24 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libstdc++-5-dev amd64 5.4.0-6ubuntu1~16.04.2
Err:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcc1-0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Ign:25 http://security.ubuntu.com/ubuntu xenial-security/main amd64 g++-5 amd64 5.4.0-6ubuntu1~16.04.2
Get:26 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 g++ amd64 4:5.3.1-1ubuntu1 [1,504 B]
Get:27 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 make amd64 4.1-6 [151 kB]
Get:28 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libdpkg-perl all 1.18.4ubuntu1.1 [195 kB]
Get:29 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial-updates/main amd64 dpkg-dev all 1.18.4ubuntu1.1 [584 kB]
Get:30 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 build-essential amd64 12.1ubuntu2 [4,758 B]
Get:31 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libfakeroot amd64 1.20.2-1ubuntu1 [25.5 kB]
Get:32 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 fakeroot amd64 1.20.2-1ubuntu1 [61.8 kB]
Err:11 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgomp1 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Get:33 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 icu-devtools amd64 55.1-7 [165 kB]
Get:34 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-diff-perl all 1.19.03-1 [47.6 kB]
Get:35 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-diff-xs-perl amd64 0.04-4build1 [11.0 kB]
Get:36 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-merge-perl all 0.08-3 [12.0 kB]
Ign:37 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcurl3 amd64 7.47.0-1ubuntu2.1
Ign:38 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcurl4-openssl-dev amd64 7.47.0-1ubuntu2.1
Get:39 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libfile-fcntllock-perl amd64 0.22-3 [32.0 kB]
Get:40 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libsepol1-dev amd64 2.4-2 [249 kB]
Get:41 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre16-3 amd64 2:8.38-3.1 [144 kB]
Get:42 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre32-3 amd64 2:8.38-3.1 [136 kB]
Get:43 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre3-dev amd64 2:8.38-3.1 [525 kB]
Err:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libitm1 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Get:44 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libselinux1-dev amd64 2.4-3build2 [122 kB]
Get:45 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libfuse-dev amd64 2.9.4-1ubuntu3.1 [105 kB]
Get:46 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libicu-dev amd64 55.1-7 [8,546 kB]
Err:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libatomic1 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:14 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libasan2 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Get:47 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libxml2-dev amd64 2.9.3+dfsg1-1ubuntu0.1 [743 kB]
Err:15 http://security.ubuntu.com/ubuntu xenial-security/main amd64 liblsan0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:16 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libtsan0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:17 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libubsan0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Get:48 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 manpages-dev all 4.04-2 [2,048 kB]
Err:18 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcilkrts5 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:19 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libmpx0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:20 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libquadmath0 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:21 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgcc-5-dev amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:22 http://security.ubuntu.com/ubuntu xenial-security/main amd64 gcc-5 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:24 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libstdc++-5-dev amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:25 http://security.ubuntu.com/ubuntu xenial-security/main amd64 g++-5 amd64 5.4.0-6ubuntu1~16.04.2
404 Not Found [IP: 54.87.136.115 80]
Err:37 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcurl3 amd64 7.47.0-1ubuntu2.1
404 Not Found [IP: 54.87.136.115 80]
Err:38 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libcurl4-openssl-dev amd64 7.47.0-1ubuntu2.1
404 Not Found [IP: 54.87.136.115 80]
Fetched 19.0 MB in 1s (11.5 MB/s)
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_4.4.0-45.66_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/cpp-5_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libcc1-0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libgomp1_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libitm1_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libatomic1_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libasan2_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/liblsan0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libtsan0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libubsan0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libcilkrts5_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libmpx0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libquadmath0_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libgcc-5-dev_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/gcc-5_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libstdc++-5-dev_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/g++-5_5.4.0-6ubuntu1~16.04.2_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/c/curl/libcurl3_7.47.0-1ubuntu2.1_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/c/curl/libcurl4-openssl-dev_7.47.0-1ubuntu2.1_amd64.deb 404 Not Found [IP: 54.87.136.115 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


Is this an error? Why is it showing this?

Answer

make sure to update apt-get before installing any lib

$ apt-get update
$ apt-get install build-essential libxml2-dev libfuse-dev libcurl4-openssl-dev