jude jude - 14 days ago 5
Python Question

cannot load .pkl on raspberry pi

I produced the .pkl on ubuntu 14.04. ubuntu can load the .pkl file but when transferred to the raspberrypi it commit an error upon loading.below listed is the error :commits

I used from sklearn.externals import joblib. I used joblib.dump to store the .pkl and joblib.load to load the file. any solutions? i tried upgrading and updating the softwares

Answer

I solved the problem.. the version of the raspberry pi's scikit-learn and the ubuntu's scikit-learn library is not the same. After upgrading both to the present versions loading the .pkl works perfectly. I also upgraded joblib. Hope this helps those with the same problem as I am